Watchdoc - Manage port 5744 in the firewall - Error message ‘Watchdoc is not responding’
May 2025
Context
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1st case
Although Watchdoc is already installed and functioning correctly in a remote mode configuration (Watchdoc server and IIS web server installed on two different servers), we have noticed that after updating to version 6.1.0.5221, the web interfaces (administration interface and ‘My Account’ page) are inaccessible.
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2nd case
We have just installed Watchdoc v. 6.1.0.5221 in a remote mode configuration (Watchdoc server and IIS web server installed on two different servers) and when we click on the shortcut
installed on the server desktop, the web interface is inaccessible. An error message is displayed in the browser.
Error message
In both cases, instead of the administration interface and the ‘My Account’ page, the following message appears in the browser:
‘Watchdoc is not responding. A connection attempt failed because the connected party did not respond correctly after a certain amount of time, or the connection failed because the connected host did not respond.’
‘Diagnosis: the service is temporarily unavailable’:
:
Cause
New security recommendations have been in effect since Watchdoc version 6.1.0.5122: to secure communications between servers, we do not recommend installing Watchdoc in ‘remote’ mode, i.e. with an IIS web server located on a server other than the Watchdoc print server (see Watchdoc Standard - Overview).
As a result, new rules are automatically applied when installing Watchdoc (since v 6.1.0.5122) to secure communications. On the Watchdoc server:
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HTTP port 5754 and HTTPS port 5753 are open to remote access;
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port 5744 (used for communications via the .net Remoting protocol) is closed to remote access. Only communications originating from the ‘localhost’ server are authorised. Therefore, communications from a remote IIS server are blocked.
Resolution
To resolve this issue, you need to add a rule to the Watchdoc server firewall. This rule must allow the remote IIS server to access Watchdoc via TCP port 5744:
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as an administrator, access the Watchdoc server;
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access the firewall management tool. In the list of ‘inbound’ rules, there is a ‘Watchdoc Firewall Exception’ rule authorising access via ports 5754 and 5753:

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In the list of ‘inbound’ rules, add the following rule:
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TCP port 5744
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Remote IP address > this IP address: enter the address of the remote website.WD_MaJ_Deport_FirewallDetail.png
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From the server, restart a browser and check that the interfaces are accessible again.
N.B.: If Watchdoc is installed in a domain (master/slave configuration), repeat this modification on all other servers in the domain.
